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2.1 How the Multi-State Lamp is Used

Multi-state lamp parts display drawing objects. The value of a specified word device is used to switch the drawing 

object to be displayed.

• Switch and display pictures by device values

*1 HG2G-S/-5S/-5F, HG3G/4G only

2 Multi-State Lamps

HG3GHG2G-5FHG2G-5SHG2G-S HG4G HG1F HG2F HG2S HG3F HG4F

External device
MICRO/I

D0

bit15 bit0bit3

D0= 0100

bit0bit3

D0= 0001

bit0bit3

D0= 0010

bit0bit3

D0= 0000

bit0bit3

 State: 0State: 1State: 2 OFF

(None)

*1
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• Display a picture when in the OFF state.*1

*1 HG2G-S/-5S/-5F, HG3G/4G only

MICRO/I
External device

D0

bit15 bit0bit3

D0= 0100

bit0bit3

D0= 0001

bit0bit3

D0= 0010

bit0bit3

D0= 0000

bit0bit3

OFF State: 0State: 1State: 2

The conditions to display the picture set by the OFF state*1 on the screen are as follows.

• Y is selected under Flash on the State tab and the trigger condition is not satisfied.

• Switching Method on the General tab is Bit, and the all bit are 0 or a bit not allocated a picture is 1.

• Switching Method on the General tab is Value, and the value of device is a number not allocated a 

picture.
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2.2 Multi-State Lamp Configuration Procedure

This section describes the configuration procedure for Multi-State Lamps.

1 On the Home tab, in the Parts group, click Lamps, and then click Multi-State Lamp.

2 Click a point on the edit screen where you wish to place the Multi-State Lamp.

3 Double-click the dropped Multi-State Lamp and a Properties dialog box will be displayed.

4 Change the settings on each tab as necessary.

The Options tab only appears in Advanced mode.

To switch to Advanced mode, click Advanced.
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2.3 Properties of Multi-State Lamp Dialog Box

This section describes items and buttons on the properties dialog box.

General Tab

Part Name

Enter a name for the part. The maximum number is 20 characters.

Switching Method

Specify the method to switch drawing objects from the following:

*1 HG2G-S/-5S/-5F, HG3G/4G only

Bit: Switches the drawing object displayed, according to the status of the bits.

Example 1: Bit is selected. The bits triggered in device D0 corresponds to the following pictures and the 

OFF state*1 is None.

Switches the picture to display according to the status of the bits.

bit15 bit0bit3

Value of Trigger Device D0

Picture

State:  0 State:  1State:  2

(None)

OFF
*1

Display picture 

for bit 0

Display picture 

for bit 1

Display picture 

for bit 2
No picture

Display picture 

for bit 1

Display picture 

for bit 2

0001 0010 0100 1000 1110 1100

State:  0 State:  1 State:  1State:  2 State: 2

Picture to display

Bit state of 

Trigger Device D0

Action

I f  mu l t ip le  b i t s  a re  1 ,  

display the picture for the 

lowest order bit.

If all bits in the device are 0 or if a 

bit with no associated picture 

becomes 1, display nothing.
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*1 HG2G-S/-5S/-5F, HG3G/4G only

Example 2: Bit is selected. The bits of trigger device D0 and the OFF state are allocated to the following 

pictures.*1

Switches the picture to display according to the status of the bits.

Value: Switches the drawing object displayed, according to the value of the device.

Example 3: Value is selected. The value assigned to the trigger device D0 are allocated to the following 

pictures and the OFF state*1 is None.

Switches the picture to display according to the value of the device.

Example 4: Value is selected. The values assigned in trigger device D0 and the OFF state are allocated 

to the following pictures.*1

Switches the picture to display according to the value of the device.

bit15 bit0bit3

Value of Trigger Device D0

Picture

State:  0 State:  1State:  2 OFF
*1

OFF

Display picture 

for bit 0

Display picture 

for bit 1

Display picture 

for bit 2

Display picture 

for OFF state

Display picture 

for bit 1

Display picture 

for bit 2

0001 0010 0100 1000 1110 1100

State:  0 State:  1 State:  1State:  2 State: 2

Picture to display

Bit state of 

Trigger Device D0

Action

I f  mu l t ip le  b i t s  a re  1 ,  

display the picture for the 

lowest order bit.

If all bits in the device are 0 or if a 

bit with no associated picture 

becomes 1, display the picture for 

0 1 2Value of Trigger Device D0

Picture

State: 2State:  1State:  0

(None)

OFF
*1

Display picture for 0 Display picture for 1 Display picture for 2 No picture

0 1 2 3

State:  0 State:  1 State: 2

Picture to display

Value of 

Trigger Device D0

Action

If the value of device 

has no picture associated 

with it, display nothing.

OFF

0 1 2Value of Trigger Device D0

Picture

State: 2State:  1State:  0
*1

OFF

Display picture 

for 0

Display picture 

for 1

Display picture 

for 2

Display picture 

for OFF state

0 1 2 3

State:  0 State:  1 State: 2

Picture to display

Value of 

Trigger Device D0

Action

If the value of device has no

picture associated with it, 

display the picture for OFF 

state.
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Trigger Device

Specifies the word device to use as the condition for switching the drawing object.

Click  to display the Device Address Settings dialog box. For the device address configuration procedure, refer 

to Chapter 2 “5.1 Device Address Settings” on page 2-67.
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View Tab

Image Type
Select the type of graphic to be used to represent the part.

Recover Background*1

Select this check box to recover the background of the area where the picture had been displayed after the picture is 

switched. When this check box is cleared, the background is filled with the screen's Background Color.

When parts or drawings are arranged so they overlap the background of the Multi-State Lamp (below), the 

background of parts and drawings is displayed as follows if the Multi-State Lamp picture is hidden.

Can only be set when Picture is selected for Image Type.

For the HG2G-5F and the HG3G/4G, the function to recover the background is always enabled, so this item is not 

displayed. However, when the background part is the Alarm List Display, Alarm Log Display, bar chart, line chart, or 

pie chart, the missing sections will remain.

*1 Advanced mode only

Standard: Uses the default graphic for WindO/I-NV2.

Picture: Uses an image file saved using Picture Manager.
For details about image file restrictions, refer to Chapter 2 “1.5 Available Image Files” on page 2-20.

MulC-State Lamp

Check box cleared Check box selected

Drawing

Since background parts and 

drawings are redrawn, they 

return to their original state.

The screen is filled with 

Background Color, so 

background parts and 

drawings are missing.

If the Recover Background check box is selected, the number of parts that can be placed on a single 

screen decreases. If an error message appears when the Multi-State Lamp is displayed on the MICRO/I 

screen, clear the Recover Background check box or reduce the number of parts.
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Coordinates

Size

X, Y: Sets the display position of parts using coordinates.

The X and Y coordinates of parts is defined relative to an origin at the top-left corner of the screen.

X: 0 to (base screen horizontal size - 1)

Y: 0 to (base screen vertical size - 1)

(0, 0)

X

Y
Screen

Parts

W, H: Sets width and height to define the size of parts.

W: 5 to (base screen horizontal size)

H: 5 to (base screen vertical size)

Width

Height

Screen

Parts



WindO/I-NV2 User’s Manual 9-23

2 Multi-State Lamps

9

L
a
m

p
s

Registration Text Tab

Font

Selects the font used for displaying text from the following.

Japanese, European, Chinese, Taiwanese, Korean, Central European, Baltic, Cyrillic, Windows, Stroke

Can only be set when the Use Text Manager check box is cleared.

The characters that can be displayed depend on the font. For details, refer to Chapter 2 “1.3 Available Text” on page 

2-6.

Size

Sets the character size (8 to 128).

Can only be set when Stroke is selected.

Style

Selects Regular or Bold for text style.

Can only be set when Font is set to Japanese, European, Chinese, Taiwanese, Korean, Central European, 

Baltic or Cyrillic.

Magnification

Can only be set when Font is set to Japanese, European, Chinese, Taiwanese, Korean, Central European, 

Baltic or Cyrillic.

Align Text Vertical

Selects text alignment in the vertical direction.

Top, Center, Bottom

For details, refer to Appendix “5 Text Alignment” on page A-5.

Align Text Horizontal

Selects text alignment in the horizontal direction.

Left, Center, Right, Center-Left

For details, refer to Appendix “5 Text Alignment” on page A-5.

Set by State

Select this check box if displaying different text when ON and OFF.

Use Text Manager

Select this check box if using the text registered in Text Manager for text display.

*1 5 to 7 are only for the HG2G-S/-5S/-5F and HG3G/4G.

W, H: Selects the magnification (0.5, 1 to 8*1) for text display.
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State Tab

Number of States

Specify the number of drawing objects (1 to 16) to display by switching.

Settings

Lists the state settings. The list shows various settings such as the state number and file name for the drawing object.

*1 HG2G-S/-5S/-5F, HG3G/4G only

State: Shows the OFF state*1 and state number. Double clicking the cell displays the State Settings 
dialog box where you can edit the state settings. For details, refer to “State Settings dialog box” 
on page 9-26.

Image: Shows the name or a file name for a drawing object. Double clicking the cell opens the View 
Browser if Standard is selected under Image Type on the View tab, or Picture Manager if 
Picture is selected. This allows you to change the drawing object to display.

Text: Shows the registration text. Double clicking the cell displays the Unicode Input dialog box. If 
you selected the Use Text Manager check box on the Registration Text tab, the Text 
Manager dialog box will appear. This allows you to change the registration text.

Fg.Color, Bg.Color: Shows the foreground and background colors (color: 256 colors, monochrome: 16 shades) for 
standard images. Double clicking the cell opens the Color Palette where you can change the 
foreground and background colors. This setting can only be changed if Image Type is set to 
Standard on the View tab.

Pattern: Shows the pattern for standard images. Double clicking the cell opens the Pattern Palette where 
you can change the pattern of the image. This setting can only be changed if Image Type is set 
to Standard on the View tab.

Text Color Shows the color of the registration text. Double clicking the cell opens the Color Palette where 
you can change the color of the text.

Flash: Indicates whether to display the drawing object flashing or constantly lit. Double clicking the cell 
toggles between Y for yes and N for no. If Y is selected, the picture which corresponds to a bit 
state or value of device is alternately shown and hidden at a fixed time interval.

However, if the OFF state*1 is set, the picture that corresponds to a bit state or value of device 

and the picture set for the OFF state*1 are alternately displayed at a fixed time interval.

Windows Font: Shows the currently set Windows Font. Double clicking the cell displays the Font Settings 
dialog box where you can change the Windows Font. This setting can only be changed when 
Windows is selected for Font on the Registration Text tab.

Set: Registers the state settings to the list. If you select the OFF state*1 or state number that is 
already registered, that number is overwritten with the new settings.
Click this button to display the State Settings dialog box. For details, refer to “State Settings 
dialog box” on page 9-26.

Insert: Inserts the settings in the position selected on the list.
Select a state number in the list and click this button to display the State Settings dialog box. 
The settings at the insertion point shift down one line. Settings cannot be inserted if all state 
numbers are configured.

Remove: Deletes the registered settings from the list.

Select the OFF state*1 or state number and click this button to delete the selected settings from 
the list.

When the OFF state is not set

When ON

When OFF

Flash

When the OFF state is set

Flash

No picture is 

shown.

Shows the picture set 

for the OFF state

Shows the picture that 

corresponds to the bit 

state or device value

Shows the picture that 

corresponds to the bit 

state or device value
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Image

Shows the image for the OFF state*1 or state number selected in the Settings list.

Copy to next State

Select this check box to register or change all state settings at once.

This option copies the current settings to all state numbers after the selected state number when the settings are set 

or changed. This option can only be set when a state number is selected.

*1 HG2G-S/-5S/-5F, HG3G/4G only
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State Settings dialog box

This dialog box sets the drawing object and registration text to display.

Image

Text

Enter the text to display. The maximum number is 3,750 characters.
The characters that can be entered depends on the font selected for Font on the Registration Text tab. For details, 
refer to Chapter 2 “1.3 Available Text” on page 2-6.
This setting is only enabled when the Use Text Manager check box is cleared on the Registration Text tab.

Text ID

To use the text registered in the Text Manager, specify the ID number from 1 to 32000.
This setting is only enabled when the Use Text Manager check box is selected on the Registration Text tab.

Color

Windows Font

Specify the Windows Font to use.
The current settings are displayed by selecting Windows in the Font property on the Registration Text tab. To 
change the settings, click Change to display the Font Settings dialog box.
The text ID setting is only enabled if the Use Text Manager check box is cleared.
For details, refer to Chapter 2 “Windows Font” on page 2-13.

*1 HG2G-S/-5S/-5F, HG3G/4G only

Browse: Select the drawing object to use for the lamp part. Clicking this button opens the View Browser 
if Standard is selected under Image Type on the View tab, or Picture Manager if Picture is 
selected.

Image: Shows the selected drawing object.

Foreground Color, Background Color:

Select the foreground and background color to use for standard images (color: 256 colors, 
monochrome: 16 shades).
Clicking either button opens the Color Palette. Select a color from the Color Palette.

Pattern: Select the pattern for a standard image. 
Clicking this button opens the Pattern Palette. Select a pattern from the Pattern Palette.

Text Color: Select the text color (color: 256 colors, monochrome: 16 shades) for the registration text.
Clicking this button opens the Color Palette. Select a color from the Color Palette.

Flash: Select this check box to make the picture flash (alternately show and hide the picture that 
corresponds to the bit state or device value at a fixed time interval).
The flashing interval can be set with the Flashing Cycle setting on the System tab of the 

Project Settings dialog box. This option cannot be set for the OFF state*1.
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Trigger Condition Tab

The Trigger Condition tab is displayed in Advanced mode.

Visible Condition

The Multi-State Lamp is displayed while the condition is satisfied. The Multi-State Lamp is hidden while the condition 
is not satisfied.

Example: When Trigger Type is While ON and Device is LM 0
While LM 0 is 0, the condition is not satisfied and the Multi-State Lamp is hidden.
While LM 0 is 1, the condition is satisfied and the Multi-State Lamp is displayed.

HG3GHG2G-5FHG2G-5SHG2G-S HG4G HG1F HG2F HG2S HG3F HG4F

Trigger Type: Selects the condition to display the Multi-State Lamp from the following.

Always visible: The Multi-State Lamp is always displayed.

LM0:

MICRO/I

0

LM0: 1
Show

Condition 

Not 

satisfied

Condition 

Satisfied

Hide

Always show

Multi-State 

Lamp state
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While ON: Displays the Multi-State Lamp when the device value is 1.

While OFF: Displays the Multi-State Lamp when the device value is 0.

While satisfying the condition:

Displays the Multi-State Lamp when the condition is satisfied.

Data Type: Selects the type of data handled by the conditional expression for the visible condition.

This option can only be configured if While satisfying the condition is selected for Trigger Type.

For details, refer to Chapter 2 “1.2 Available Data” on page 2-2.

Device: Specifies the bit device or bit of the word device to serve as the visible condition.

This option can only be configured when While ON or While OFF is selected for Trigger Type.

Click  to display the Device Address Settings dialog box. For the device address configuration 

procedure, refer to Chapter 2 “5.1 Device Address Settings” on page 2-67.

Condition: Specifies the conditional expression for the visible condition.

This option can only be configured when While satisfying the condition is selected for Trigger 

Type.

Click  to display the Trigger Condition Settings dialog box. For the conditional expression 

configuration procedure, refer to Chapter 2 “5.2 Setting Conditional Expressions” on page 2-69.

Comment: Used for entering a comment for the visible condition. The maximum number is 80 characters.

1

0

Hide Show Hide HideShow Show

Device value

Multi-State 

Lamp state

1

0

Show Show ShowHide Hide Hide

Multi-State 

Lamp state

Hide Hide HideShow Show Show

Multi-State 

Lamp state

Satisfied

Not satisfied

Condition
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Options Tab

The Options tab is displayed in Advanced mode.

Security Group

Security groups are a security function for restricting the display and operation of parts.

Display: Selects the security group for which display of parts is restricted. (Default: None)

None: No security function is used.

Administrator, Operator, Reader: Three security groups are set up by default.

Click  to display the Security Group Settings dialog box. If you create a security group on the 

Security Group Settings dialog box, you can select that created group. For details, refer to Chapter 23 

“2.2 Adding and Editing Security Groups” on page 23-18.

For details about security functions, refer to Chapter 23 “User Accounts and the Security Function” on page 

23-1.
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Example: If the user and security group for a part are set as follows:

For User 1, who is not included in the specified security group, Group A parts are not displayed.

If the Password Screen is now opened and a switch is made to User 2 of Group A, Group A parts are displayed.

User Name

Security Group None Group A

User1 User2

MICRO/I

130Line Chart and Bar Chart

Display: Group A

Bu[on

Display: Group A

Numerical Display

Display: None

Open Password Screen, 

enter password, 

and switch to User2

Group A parts are 

not displayed to User1
Group A parts are 

displayed to User2

MICRO/I

130

MICRO/I MICRO/I

130

User1 User2

130
CAN

User Up Down

A B C D E F

G H I J K L

CLR

M N O P Q R

S T U V W X

ENT

Y Z 0 1 2 3

4 5 6 7 8 9

Password
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Comment Tab

The Comment tab is used to specify the parts arranged on the editing screen, and the popup text displayed when 

the mouse pointer is placed close to No., Name, or Type in the object list.

Description

Used for entering comments about parts. The maximum number is 80 characters.

Example: When mousing over the Multi-State Lamp on the editing screen

When there are multiple parts of the same shape on the screen, this features makes it possible to 

distinguish between the parts without displaying the Properties dialog box for each part, by just mousing 

over the part.


